Eğer Formülü Excel’de (IF formülü olarak da bilinir) bir koşul koşulumuza göre verileri değerlendirmeye ve sonuç üretebilmeye yarar. Örneğin, bir çalışanın çalışma süresine göre maaşını belirleyebilir, ya da bir öğrencinin notuna göre geçip geçmediğini belirleyebiliriz.

Eğer” formülünü kullanırken, öncelikle koşulumuzu yazmalıyız. Koşul doğru ise yapılacak işlemleri belirtmeli, yanlış ise yapılacak işlemleri belirtmeliyiz. Bu iki işlem için de bir değer veya formül belirtebiliriz.

Formülümüz şu şekilde yazılır:

=EĞER(koşul, doğru_işlem, yanlış_işlem)

Koşul, doğru_işlem ve yanlış_işlem alanlarına, herhangi bir değer veya formül yazılabilir. Örneğin, bir öğrencinin notunun 70 ve üstünde olup olmadığını kontrol etmek istiyorsak şu şekilde bir formül yazabiliriz:

=EĞER(B2>=70, “Geçti”, “Kaldı”)

Bu formül, B2 hücresinde yer alan değerin 70 ve üstünde olup olmadığını kontrol eder. Eğer değer 70 ve üstündeyse “Geçti” yazdırır, değilse “Kaldı” yazdırır.

Eğer” formülünün birkaç örnek daha vermek gerekirse:

  • Bir çalışanın çalışma süresine göre maaşını belirlemek için: =EĞER(B2<2, B250, B2100)

Bu formül, B2 hücresinde yer alan çalışma süresinin 2 yıldan az olup olmadığını kontrol eder. Eğer çalışma süresi 2 yıldan az ise, çalışma süresine göre 50 TL ücret verir, değilse 100 TL ücret verir.

  • Bir ürünün stok sayısına göre “Stokta var” veya “Stokta yok” gibi bir mesaj üretmek için: =EĞER(B2>0, “Stokta var”, “Stokta yok”)

Bu formül, B2 hücresinde yer alan stok sayısının 0’dan büyük olup olmadığını kontrol eder. Eğer stok sayısı 0’dan büyükse “Stokta var” yazdırır, değilse “Stokta yok” yazdırır.

  • Bir öğrencinin yaşına göre “Çocuk” veya “Yetişkin” gibi bir kategoride olup olmadığını belirlemek için: =EĞER(B2<18, “Çocuk”, “Yetişkin”)

Bu formül, B2 hücresinde yer alan öğrencinin yaşının 18’den küçük olup olmadığını kontrol eder. Eğer yaş 18’den küçükse “Çocuk” yazdırır, değilse “Yetişkin” yazdırır.

Bu örneklerde gördüğünüz gibi, “Eğer” formülü ile bir koşulumuza göre verileri değerlendirip, sonuç üretebiliriz. Formülün yapısını anladıktan sonra, kolaylıkla kendi formüllerinizi oluşturabilirsiniz.

Eğer” formülünün birkaç özel durumunu da açıklamaya çalışayım:

  • Eğer formülü içerisinde birden fazla koşul kullanmak isterseniz, AND veya OR fonksiyonlarını kullanabilirsiniz. Örneğin, bir öğrencinin notunun 50 ve üstünde olması ve sınavdan geçtiğini belirlemek istiyorsak şu formülü kullanabiliriz: =EĞER(AND(B2>=50, C2=”Geçti”), “Tebrikler!”, “Malesef”)

Bu formül, B2 hücresinde yer alan notun 50 ve üstünde olup olmadığını ve C2 hücresinde yer alan “Geçti” değerinin olup olmadığını kontrol eder. Eğer iki koşul da doğru ise “Tebrikler!” yazdırır, değilse “Malesef” yazdırır.

  • Eğer formülü içerisinde bir koşul değerlendirmeye alınmasın istiyorsanız, ISBLANK fonksiyonunu kullanabilirsiniz. Örneğin, bir çalışanın maaşını belirlerken maaş bilgisi girilmemiş ise “Maaş bilgisi girilmedi” mesajını üretebiliriz: =EĞER(ISBLANK(B2), “Maaş bilgisi girilmedi”, B2*30)

Bu formül, B2 hücresinin boş olup olmadığını kontrol eder. Eğer boş ise “Maaş bilgisi girilmedi” yazdırır, değilse B2 hücresinde yer alan maaş bilgisine göre çalışanın maaşını 30 ile çarparak yazdırır.

Bu özel durumları da dikkate alarak, “Eğer” formülünü daha verimli bir şekilde kullanabilirsiniz. Umarım bu bilgiler de faydalı olmuştur. Eğer Formülü Hakkında daha fazla bilgiye ihtiyaç duyarsanız, lütfen yorumlarda bunu sorun!